Yesterday I upgraded from Windows 7 to Windows 10, and noticed that the text in DMB looked slightly "blurry" after the upgrade. I've learned that this is related to the default display settings in Windows 10, and that applications which don't have "DPI awareness" may not look right. Here are the steps I took to fix the problem:

1) Navigate to the Diamond Mind folder, for example C:\dmb11\
2) Locate the "baseball.exe" application
3) Right-click on the baseball.exe file, and choose Properties
4) Click on the Compatibility tab
5) Check the box next to "Disable display scaling on high DPI settings"
6) Click OK

After that change, the text looked normal in DMB, and no longer blurry. Just wanted to let others know in case you're seeing a similar issue.

Jeff